Dash Maintenance

Completed
Scheduled for February 17, 2023 at 5:00 AM – 7:00 AM

Affected

Web Applications
Updates
  • Completed
    February 17, 2023 at 7:00 AM
    Completed
    February 17, 2023 at 7:00 AM

    Maintenance has completed successfully

  • In progress
    February 17, 2023 at 5:00 AM
    In progress
    February 17, 2023 at 5:00 AM

    Maintenance is now in progress

  • Planned
    February 17, 2023 at 5:00 AM
    Planned
    February 17, 2023 at 5:00 AM

    We will conduct system maintenance for Dash on February 16th at 9:00 PM PST for 2 hours.

    We do not expect any system interruption while doing this maintenance.

    We will share live status updates and the outcome of our performance improvements on our real-time status site, status.virtualpbx.com, where you may also subscribe to updates via email, SMS, or RSS feed.

    If you have any questions, please feel free to reach out to us by phone, email, or online chat. Thank you for your understanding.