Scheduled for February 12, 2025 at 3:00 AM – 9:00 AM
Affects
Web Applications
Under maintenance from 3:00 AM to 9:00 AM
Completed
February 12, 2025 at 9:00 AMCompleted
February 12, 2025 at 9:00 AMMaintenance has completed successfully
In progress
February 12, 2025 at 3:00 AMIn progress
February 12, 2025 at 3:00 AMMaintenance is now in progress
Planned
February 12, 2025 at 3:00 AMPlanned
February 12, 2025 at 3:00 AMWe will conduct system maintenance for Dash on February 11th at 7:00 PM PST for 6 hours.
We do not expect any system interruption during this maintenance.
We will share live status updates and the outcome of our performance improvements on our real-time status site, status.virtualpbx.com, where you may also subscribe to updates via email, SMS, or RSS feed.
If you have any questions, please feel free to reach out to us by phone, email, or online chat. Thank you for your understanding.